#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\$[\d+,]{,100})"
Local $sString = "Ваша ассоциация наняла рабочего Стэнфорд Флеминг за $208,000,000. Основным соперником была ассоциация Путь со ставкой $195,440,000." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Следующие игроки приняли участие в аукционе:" & @CRLF & _
"" & @CRLF & _
"DikoBrazzers: $28,450,000" & @CRLF & _
"" & @CRLF & _
"рус73: $27,880,000" & @CRLF & _
"" & @CRLF & _
"TANK1515: $20,110,000" & @CRLF & _
"" & @CRLF & _
"Крысолов: $20,000,000" & @CRLF & _
"" & @CRLF & _
"Валентинович 55: $19,860,000" & @CRLF & _
"" & @CRLF & _
"Slepoy 16ru: $15,000,000" & @CRLF & _
"" & @CRLF & _
"Виктор 74: $13,680,000" & @CRLF & _
"" & @CRLF & _
"корефанец: $10,850,000" & @CRLF & _
"" & @CRLF & _
"Папа Djo: $10,210,000" & @CRLF & _
"" & @CRLF & _
"Кадима: $10,020,000" & @CRLF & _
"" & @CRLF & _
"Aleks Mechanic: $9,410,000" & @CRLF & _
"" & @CRLF & _
"пожик47: $9,300,000" & @CRLF & _
"" & @CRLF & _
"super_skif: $7,590,000" & @CRLF & _
"" & @CRLF & _
"Лoки: $5,640,000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")