re = /(?:\$[\d+,]{,100})/m
str = 'Ваша ассоциация наняла рабочего Стэнфорд Флеминг за $208,000,000. Основным соперником была ассоциация Путь со ставкой $195,440,000.
Следующие игроки приняли участие в аукционе:
DikoBrazzers: $28,450,000
рус73: $27,880,000
TANK1515: $20,110,000
Крысолов: $20,000,000
Валентинович 55: $19,860,000
Slepoy 16ru: $15,000,000
Виктор 74: $13,680,000
корефанец: $10,850,000
Папа Djo: $10,210,000
Кадима: $10,020,000
Aleks Mechanic: $9,410,000
пожик47: $9,300,000
super_skif: $7,590,000
Лoки: $5,640,000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end