$re = '/(\w+\[\w+\,\w+\])/';
$str = 'aaaa[zzzz,zz],bbb,ccc[zzzz,zz],dddd';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;