using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+\[\w+\,\w+\])";
string substitution = @"";
string input = @"aaaa[zzzz,zz],bbb,ccc[zzzz,zz],dddd";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}