const regex = /(\w+\[\w+\,\w+\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+\\[\\w+\\,\\w+\\])', 'g')
const str = `aaaa[zzzz,zz],bbb,ccc[zzzz,zz],dddd`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);