$re = '/(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*/m';
$str = '<?xml version="1.0" encoding="UTF-8"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading> * + Reminder + * </heading>
<body>Don\'t forget
me this weekend!
</body>
</note>
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;