# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*/$1/gm;t' <<< "<?xml version=\"1.0\" encoding=\"UTF-8\"?>
<note>
<to>Tove</to>
<from>Jani</from>
<heading> * + Reminder + * </heading>
<body>Don't forget
me this weekend!
</body>
</note>
"