#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=>)\s*([^<]*[^\s<])\s*(?=<)|(?<=>)\s*"
Local $sString = "<?xml version="1.0" encoding="UTF-8"?>" & @CRLF & _
"<note>" & @CRLF & _
" <to>Tove</to>" & @CRLF & _
" <from>Jani</from>" & @CRLF & _
" <heading> * + Reminder + * </heading>" & @CRLF & _
" <body>Don't forget" & @CRLF & _
" me this weekend! " & @CRLF & _
" </body>" & @CRLF & _
"</note> " & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)