# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=.*\d)^(Rp|Rp )?(([1-9]\d{0,2}((\.\d{3})*|\d+))|(0+[1-9]+(\d+|(\.\d{3})*)))(,\d{1,2})?$"
test_str = ("18.215\n"
"Rp17500\n"
"Rp17.500,00\n"
"Rp 120.325\n"
"005.000.000.100\n"
"001100\n"
"10\n"
"20000000\n"
"100000000\n"
"100000001\n"
"1000\n"
"3000 Rp\n"
"Rp \n"
"0.999\n"
"-1,000\n"
"-10\n"
"1.1000\n"
"17,500\n"
"2 500\n"
"005.1a2\n"
"ram123.12213\n"
"ramdan890.9090909")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.