#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*\d)^(Rp|Rp )?(([1-9]\d{0,2}((\.\d{3})*|\d+))|(0+[1-9]+(\d+|(\.\d{3})*)))(,\d{1,2})?$"
Local $sString = "18.215" & @CRLF & _
"Rp17500" & @CRLF & _
"Rp17.500,00" & @CRLF & _
"Rp 120.325" & @CRLF & _
"005.000.000.100" & @CRLF & _
"001100" & @CRLF & _
"10" & @CRLF & _
"20000000" & @CRLF & _
"100000000" & @CRLF & _
"100000001" & @CRLF & _
"1000" & @CRLF & _
"3000 Rp" & @CRLF & _
"Rp " & @CRLF & _
"0.999" & @CRLF & _
"-1,000" & @CRLF & _
"-10" & @CRLF & _
"1.1000" & @CRLF & _
"17,500" & @CRLF & _
"2 500" & @CRLF & _
"005.1a2" & @CRLF & _
"ram123.12213" & @CRLF & _
"ramdan890.9090909"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")