import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\d)^(Rp|Rp )?(([1-9]\\d{0,2}((\\.\\d{3})*|\\d+))|(0+[1-9]+(\\d+|(\\.\\d{3})*)))(,\\d{1,2})?$";
final String string = "18.215\n"
+ "Rp17500\n"
+ "Rp17.500,00\n"
+ "Rp 120.325\n"
+ "005.000.000.100\n"
+ "001100\n"
+ "10\n"
+ "20000000\n"
+ "100000000\n"
+ "100000001\n"
+ "1000\n"
+ "3000 Rp\n"
+ "Rp \n"
+ "0.999\n"
+ "-1,000\n"
+ "-10\n"
+ "1.1000\n"
+ "17,500\n"
+ "2 500\n"
+ "005.1a2\n"
+ "ram123.12213\n"
+ "ramdan890.9090909";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}