import Foundation
let pattern = #"("ControlLabel": ")(.*)(",\n\s*)("ControlOptions":.*)(Select all that apply:\\r\\n)(.*)(\n\s*"ControlType": ")(OneResponse")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
}, {
"ControlLabel": "How the post-op instructions were given",
"ControlOptions": "Select all that apply:\r\ncomputer generated\r\nverbal\r\nwritten",
"ControlType": "OneResponse",
"Descript": "Post-Op Instructions"
}, {
"ControlLabel": "The degree of scaling",
"ControlOptions": "general\r\nlight",
"ControlType": "MultiResponse",
"Descript": "Prophy Scaling"
}, {
"ControlLabel": "The quadrants",
"ControlOptions": "Select all that apply:\r\nUpper Right\r\nUpper Left\r\nLower Right\r\nLower Left",
"ControlType": "OneResponse",
"Descript": "Quadrant-Select Multiple"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2. Select all that apply.\3\4\6\7MultiResponse""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)