import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"ControlLabel\": \")(.*)(\",\\n\\s*)(\"ControlOptions\":.*)(Select all that apply:\\\\r\\\\n)(.*)(\\n\\s*\"ControlType\": \")(OneResponse\")";
final String string = " }, {\n"
+ " \"ControlLabel\": \"How the post-op instructions were given\",\n"
+ " \"ControlOptions\": \"Select all that apply:\\r\\ncomputer generated\\r\\nverbal\\r\\nwritten\",\n"
+ " \"ControlType\": \"OneResponse\",\n"
+ " \"Descript\": \"Post-Op Instructions\"\n"
+ " }, {\n"
+ " \"ControlLabel\": \"The degree of scaling\",\n"
+ " \"ControlOptions\": \"general\\r\\nlight\",\n"
+ " \"ControlType\": \"MultiResponse\",\n"
+ " \"Descript\": \"Prophy Scaling\"\n"
+ " }, {\n"
+ " \"ControlLabel\": \"The quadrants\",\n"
+ " \"ControlOptions\": \"Select all that apply:\\r\\nUpper Right\\r\\nUpper Left\\r\\nLower Right\\r\\nLower Left\",\n"
+ " \"ControlType\": \"OneResponse\",\n"
+ " \"Descript\": \"Quadrant-Select Multiple\"";
final String subst = "\\1\\2. Select all that apply.\\3\\4\\6\\7MultiResponse\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}