package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+) (\w+)`)
var str = `ABC 123 Book 456 ZZZ 789 KKK XYZ`
var substitution = "\2 \1"
fmt.Println(re.ReplaceAllString(str, substitution))
}