#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d+) (\w+)"
Local $sString = "ABC 123 Book 456 ZZZ 789 KKK XYZ"
Local $sSubst = "\2 \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)