# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+) (\w+)/\2 \1/gm;t' <<< "ABC 123 Book 456 ZZZ 789 KKK XYZ"