import Foundation
let pattern = #"<[^"]*class="[^"]*(?<="|\s)marginRight(?="|\s[^"]*)"[^"]*href="(?<url>([^?][^\d+]*(?<number>\d+))[^"]*)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span class="nav-next-btn nohistory FloatRight">
<span class="nav-next-btn nohistory marginRight">
<a href="http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1" title="Go to next page">
Next ›
</a>
</span>
<a href="http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1" title="Go to last page">
Last »
</a>
</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)