#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<[^"]*class="[^"]*(?<="|\s)marginRight(?="|\s[^"]*)"[^"]*href="(?<url>([^?][^\d+]*(?<number>\d+))[^"]*)""
Local $sString = "<span class="nav-next-btn nohistory FloatRight">" & @CRLF & _
" " & @CRLF & _
" <span class="nav-next-btn nohistory marginRight">" & @CRLF & _
" <a href="http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1" title="Go to next page">" & @CRLF & _
" Next ›" & @CRLF & _
" </a>" & @CRLF & _
" </span>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" <a href="http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1" title="Go to last page">" & @CRLF & _
" Last »" & @CRLF & _
" </a>" & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" </span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")