import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^\"]*class=\"[^\"]*(?<=\"|\\s)marginRight(?=\"|\\s[^\"]*)\"[^\"]*href=\"(?<url>([^?][^\\d+]*(?<number>\\d+))[^\"]*)\"";
final String string = "<span class=\"nav-next-btn nohistory FloatRight\">\n"
+ " \n"
+ " <span class=\"nav-next-btn nohistory marginRight\">\n"
+ " <a href=\"http://www.mudah.my/Pahang/nike-for-sale?o=2&q=nike&so=1&th=1\" title=\"Go to next page\">\n"
+ " Next ›\n"
+ " </a>\n"
+ " </span>\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " <a href=\"http://www.mudah.my/Pahang/nike-for-sale?o=5&q=nike&so=1&th=1\" title=\"Go to last page\">\n"
+ " Last »\n"
+ " </a>\n"
+ " \n"
+ " \n"
+ " </span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}