$re = '/^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})/m';
$str = 'm.goksu0234@gmail.com
ahmetgoksu34@gmail.com.tr
kjdhfahadsfkj@hotmail.com.tr
jhkgsfglj0933@yahşoo.org
vjkaov_oka,kg.hot@bilgiedu.net
vjkaov_okakg.hot@bilgiedu.n44ff
kvkjak v,,@hotmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);