use strict;
my $str = 'm.goksu0234@gmail.com
ahmetgoksu34@gmail.com.tr
kjdhfahadsfkj@hotmail.com.tr
jhkgsfglj0933@yahşoo.org
vjkaov_oka,kg.hot@bilgiedu.net
vjkaov_okakg.hot@bilgiedu.n44ff
kvkjak v,,@hotmail.com';
my $regex = qr/^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}