package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z0-9\._]+)@([a-z]+)\.([a-z]{2,4})`)
var str = `m.goksu0234@gmail.com
ahmetgoksu34@gmail.com.tr
kjdhfahadsfkj@hotmail.com.tr
jhkgsfglj0933@yahşoo.org
vjkaov_oka,kg.hot@bilgiedu.net
vjkaov_okakg.hot@bilgiedu.n44ff
kvkjak v,,@hotmail.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}