// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img\b[^<>]*?src=(['"].*?\/)([^.\/<>]*\.[^.\/<>]*)['"][^><]*?\/>"#).unwrap();
let string = "<p>Lorem ipsum dolor sit amet.</p><img src=\"https://lh5.googleusercontent.com/-1G1Z51IFZe4/TYbMLgP8ObI/AAAAAAAAAas/WteAs_b7xzc/s320/herminafinal.jpg\" /><p>Lorem ipsum dolor sit amet.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}