const regex = /<img\b[^<>]*?src=(['"].*?\/)([^.\/<>]*\.[^.\/<>]*)['"][^><]*?\/>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img\\b[^<>]*?src=([\'"].*?\\\/)([^.\\\/<>]*\\.[^.\\\/<>]*)[\'"][^><]*?\\\/>', 'g')
const str = `<p>Lorem ipsum dolor sit amet.</p><img src="https://lh5.googleusercontent.com/-1G1Z51IFZe4/TYbMLgP8ObI/AAAAAAAAAas/WteAs_b7xzc/s320/herminafinal.jpg" /><p>Lorem ipsum dolor sit amet.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}