using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img\b[^<>]*?src=(['""].*?\/)([^.\/<>]*\.[^.\/<>]*)['""][^><]*?\/>";
string input = @"<p>Lorem ipsum dolor sit amet.</p><img src=""https://lh5.googleusercontent.com/-1G1Z51IFZe4/TYbMLgP8ObI/AAAAAAAAAas/WteAs_b7xzc/s320/herminafinal.jpg"" /><p>Lorem ipsum dolor sit amet.</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}