$re = '/(?:^\s*(?:[\w<>]+\s+){2}(?!\w+\s\{get;set;}.*$)|\G)\K(\w+)(\h*)(?=.*\s\{get;set;}.*$)/m';
$str = ' public BusinessProcessTaskStatus Status {get;set;}
public HcmEmploymentType WorkerType {get;set;}
public string OnboardedEmployeeEmail {get;set;}
public BusinessProcessGenericSubtype GenericSubtype {get;set;}
public BaseWorker Assigned worker {get;set;}
public ProcessTask Process task {get;set;}
public BaseWorker Resolved by {get;set;}
public string dataAreaId {get;set;} //PrimaryKey not null
public List<ProcessTemplateTask> Assigned template tasks {get;set;}
public List<ProcessTask> Assigned tasks {get;set;} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);