const regex = /(?:^\s*(?:[\w<>]+\s+){2}(?!\w+\s\{get;set;}.*$)|\G)\K(\w+)(\h*)(?=.*\s\{get;set;}.*$)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^\\s*(?:[\\w<>]+\\s+){2}(?!\\w+\\s\\{get;set;}.*$)|\\G)\\K(\\w+)(\\h*)(?=.*\\s\\{get;set;}.*$)', 'mg')
const str = ` public BusinessProcessTaskStatus Status {get;set;}
public HcmEmploymentType WorkerType {get;set;}
public string OnboardedEmployeeEmail {get;set;}
public BusinessProcessGenericSubtype GenericSubtype {get;set;}
public BaseWorker Assigned worker {get;set;}
public ProcessTask Process task {get;set;}
public BaseWorker Resolved by {get;set;}
public string dataAreaId {get;set;} //PrimaryKey not null
public List<ProcessTemplateTask> Assigned template tasks {get;set;}
public List<ProcessTask> Assigned tasks {get;set;} `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}