#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^\s*(?:[\w<>]+\s+){2}(?!\w+\s\{get;set;}.*$)|\G)\K(\w+)(\h*)(?=.*\s\{get;set;}.*$)"
Local $sString = " public BusinessProcessTaskStatus Status {get;set;} " & @CRLF & _
"" & @CRLF & _
" public HcmEmploymentType WorkerType {get;set;} " & @CRLF & _
"" & @CRLF & _
" public string OnboardedEmployeeEmail {get;set;} " & @CRLF & _
"" & @CRLF & _
" public BusinessProcessGenericSubtype GenericSubtype {get;set;} " & @CRLF & _
"" & @CRLF & _
" public BaseWorker Assigned worker {get;set;} " & @CRLF & _
"" & @CRLF & _
" public ProcessTask Process task {get;set;} " & @CRLF & _
"" & @CRLF & _
" public BaseWorker Resolved by {get;set;} " & @CRLF & _
" public string dataAreaId {get;set;} //PrimaryKey not null" & @CRLF & _
"" & @CRLF & _
" public List<ProcessTemplateTask> Assigned template tasks {get;set;} " & @CRLF & _
"" & @CRLF & _
" public List<ProcessTask> Assigned tasks {get;set;} "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")