const regex = /(\d+\.?\d*)|(\w+('\w+)?)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+\\.?\\d*)|(\\w+(\'\\w+)?)', 'gi')
const str = `https://prgxlabs.atlassian.net/wiki/spaces/DOD/pages/2372174691/Release-1.33-PanopticMail test's "test" 'bla'
Hi.will.you.1.33`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}