import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+\\.?\\d*)|(\\w+('\\w+)?)";
final String string = "https://prgxlabs.atlassian.net/wiki/spaces/DOD/pages/2372174691/Release-1.33-PanopticMail test's \"test\" 'bla'\n\n"
+ "Hi.will.you.1.33";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}