using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+\.?\d*)|(\w+('\w+)?)";
string input = @"https://prgxlabs.atlassian.net/wiki/spaces/DOD/pages/2372174691/Release-1.33-PanopticMail test's ""test"" 'bla'
Hi.will.you.1.33";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}