$re = '/(-100x)([0-9]*)(\.(gif|jpg|png))/';
$str = '-100x31155.png
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);