const regex = /(-100x)([0-9]*)(\.(gif|jpg|png))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-100x)([0-9]*)(\\.(gif|jpg|png))', '')
const str = `-100x31155.png
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}