package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(-100x)([0-9]*)(\.(gif|jpg|png))`)
var str = `-100x31155.png
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}