re = /require(?<one>\((?<two>(?<quote>'|\")(?<three>\.?\/?\/?[\W\w]+?)\k<quote>)\))/m
str = 'const test = require(\'./catalog.routes\');'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end