$re = '/require(?<one>\((?<two>(?<quote>\'|\")(?<three>\.?\/?\/?[\W\w]+?)\k<quote>)\))/m';
$str = 'const test = require(\'./catalog.routes\');';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);