using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"require(?<one>\((?<two>(?<quote>'|\"")(?<three>\.?\/?\/?[\W\w]+?)\k<quote>)\))";
string input = @"const test = require('./catalog.routes');";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}