# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<stat>\w+)(\s*([Dd][cC]|@)\s*(?<num>\d+))?|())\s*\]"
test_str = ("[1 min: STR-Armor Rating](swept downstream to [room L]/able to reach edge)\n"
"[1min: STR DC 12](swept downstream to [room L]/able to reach edge)\n"
"[12 hr: STR DC 12](swept downstream to [room L]/able to reach edge)\n"
"How does one [WIS@15](fail info/pass info 1)\n"
"[ssdsd](sd/ds)\n"
"[ssdsd](-/ds)\n"
"[ssdsd](player is Incapacitated for 1d4 rounds/-)\n"
"[Con](sleep for 1d6x10 minutes/-)\n"
"[Dex](2d6 damage/half)\n"
"[CON](lose 1hp every minute/-)\n"
"[STR](-/upward thrust dislodges debris - critical: door opens)\n"
"[DEX](slide down to pit/-)\n"
"[level 2 - room T]\n"
"[CON-Armor Rating](1d8 damage/-)\n"
"[STR-Armor Rating](swept downstream to [room L]/able to reach edge)\n"
"[Dex](-/pull up bracelet with chain)\n"
"[paralyze](paralyzed 3d6 turns/-)\n"
"[wis](cannot understand/-)\n"
"[poison](unconscious 1d6 turns/-)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.