#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<stat>\w+)(\s*([Dd][cC]|@)\s*(?<num>\d+))?|())\s*\]"
Local $sString = "[1 min: STR-Armor Rating](swept downstream to [room L]/able to reach edge)" & @CRLF & _
"[1min: STR DC 12](swept downstream to [room L]/able to reach edge)" & @CRLF & _
"[12 hr: STR DC 12](swept downstream to [room L]/able to reach edge)" & @CRLF & _
"How does one [WIS@15](fail info/pass info 1)" & @CRLF & _
"[ssdsd](sd/ds)" & @CRLF & _
"[ssdsd](-/ds)" & @CRLF & _
"[ssdsd](player is Incapacitated for 1d4 rounds/-)" & @CRLF & _
"[Con](sleep for 1d6x10 minutes/-)" & @CRLF & _
"[Dex](2d6 damage/half)" & @CRLF & _
"[CON](lose 1hp every minute/-)" & @CRLF & _
"[STR](-/upward thrust dislodges debris - critical: door opens)" & @CRLF & _
"[DEX](slide down to pit/-)" & @CRLF & _
"[level 2 - room T]" & @CRLF & _
"[CON-Armor Rating](1d8 damage/-)" & @CRLF & _
"[STR-Armor Rating](swept downstream to [room L]/able to reach edge)" & @CRLF & _
"[Dex](-/pull up bracelet with chain)" & @CRLF & _
"[paralyze](paralyzed 3d6 turns/-)" & @CRLF & _
"[wis](cannot understand/-)" & @CRLF & _
"[poison](unconscious 1d6 turns/-)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")