import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<stat>\\w+)(\\s*([Dd][cC]|@)\\s*(?<num>\\d+))?|())\\s*\\]";
final String string = "[1 min: STR-Armor Rating](swept downstream to [room L]/able to reach edge)\n"
+ "[1min: STR DC 12](swept downstream to [room L]/able to reach edge)\n"
+ "[12 hr: STR DC 12](swept downstream to [room L]/able to reach edge)\n"
+ "How does one [WIS@15](fail info/pass info 1)\n"
+ "[ssdsd](sd/ds)\n"
+ "[ssdsd](-/ds)\n"
+ "[ssdsd](player is Incapacitated for 1d4 rounds/-)\n"
+ "[Con](sleep for 1d6x10 minutes/-)\n"
+ "[Dex](2d6 damage/half)\n"
+ "[CON](lose 1hp every minute/-)\n"
+ "[STR](-/upward thrust dislodges debris - critical: door opens)\n"
+ "[DEX](slide down to pit/-)\n"
+ "[level 2 - room T]\n"
+ "[CON-Armor Rating](1d8 damage/-)\n"
+ "[STR-Armor Rating](swept downstream to [room L]/able to reach edge)\n"
+ "[Dex](-/pull up bracelet with chain)\n"
+ "[paralyze](paralyzed 3d6 turns/-)\n"
+ "[wis](cannot understand/-)\n"
+ "[poison](unconscious 1d6 turns/-)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}