$re = '/(?<=@20).*?(?=@50|\.|F5|AF5)/m';
$str = '@20dibur@50 sdfgghh.
@20dibur nosaf. end here@50.
@20dibur fsrtt sdfsf@50 sdfgghh.
@20dibur fsrtt F5 sdfsf@50 sdfgghh.
@20dibur fsrtt AF5 sdfsf@50 sdfgghh.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);