const regex = /(?<=@20).*?(?=@50|\.|F5|AF5)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=@20).*?(?=@50|\\.|F5|AF5)', 'gm')
const str = `@20dibur@50 sdfgghh.
@20dibur nosaf. end here@50.
@20dibur fsrtt sdfsf@50 sdfgghh.
@20dibur fsrtt F5 sdfsf@50 sdfgghh.
@20dibur fsrtt AF5 sdfsf@50 sdfgghh.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}