import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=@20).*?(?=@50|\\.|F5|AF5)";
final String string = "@20dibur@50 sdfgghh.\n"
+ "@20dibur nosaf. end here@50.\n"
+ "@20dibur fsrtt sdfsf@50 sdfgghh.\n"
+ "@20dibur fsrtt F5 sdfsf@50 sdfgghh.\n"
+ "@20dibur fsrtt AF5 sdfsf@50 sdfgghh.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}