$re = '/\$\$(?:[^(\$\$)\\\\]|\\\\.)*\$\$/';
$str = 'هذا اختبار $$الفراغات$$، يجب علينا اختبار سؤال $$الفراغات$$ $$فراغ$$
fill this $$blanks$$ and be $$aw sd%^^a re$$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);