package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\$(?:[^(\$\$)\\]|\\.)*\$\$`)
var str = `هذا اختبار $$الفراغات$$، يجب علينا اختبار سؤال $$الفراغات$$ $$فراغ$$
fill this $$blanks$$ and be $$aw sd%^^a re$$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}