#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\$\$(?:[^(\$\$)\\]|\\.)*\$\$"
Local $sString = "هذا اختبار $$الفراغات$$، يجب علينا اختبار سؤال $$الفراغات$$ $$فراغ$$ " & @CRLF & _
"" & @CRLF & _
"fill this $$blanks$$ and be $$aw sd%^^a re$$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")