re = /(?<=^ *)(?=\$(?:\{[a-z_][a-z0-9_]*\}|[a-z_][a-z0-9_]*)|[a-z_][a-z0-9_]*)(?:(?:\$\{)?([^ \}]+)\}?)(?= *$)/im
str = '### INFO
# Attempt to capture a parameter identifier inside a text selection, possibly
# wrapped in whitespace, including the following (examples using `backtick quotes`):
# - Raw word: e.g. `param_name`
# - $parameter expansion: e.g. `$param_name`
# - ${parameter} expansion e.g. `${param_name}`
### ENDINFO
testvar
testvar
test_var
test5_var
test_var5
$test_var
$test_var4
${test_var4}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end