const regex = /(?<=^ *)(?=\$(?:\{[a-z_][a-z0-9_]*\}|[a-z_][a-z0-9_]*)|[a-z_][a-z0-9_]*)(?:(?:\$\{)?([^ \}]+)\}?)(?= *$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^ *)(?=\\$(?:\\{[a-z_][a-z0-9_]*\\}|[a-z_][a-z0-9_]*)|[a-z_][a-z0-9_]*)(?:(?:\\$\\{)?([^ \\}]+)\\}?)(?= *$)', 'gim')
const str = `### INFO
# Attempt to capture a parameter identifier inside a text selection, possibly
# wrapped in whitespace, including the following (examples using \`backtick quotes\`):
# - Raw word: e.g. \`param_name\`
# - \$parameter expansion: e.g. \`\$param_name\`
# - \${parameter} expansion e.g. \`\${param_name}\`
### ENDINFO
testvar
testvar
test_var
test5_var
test_var5
\$test_var
\$test_var4
\${test_var4}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}