import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^ *)(?=\\$(?:\\{[a-z_][a-z0-9_]*\\}|[a-z_][a-z0-9_]*)|[a-z_][a-z0-9_]*)(?:(?:\\$\\{)?([^ \\}]+)\\}?)(?= *$)";
final String string = "### INFO\n"
+ "# Attempt to capture a parameter identifier inside a text selection, possibly\n"
+ "# wrapped in whitespace, including the following (examples using `backtick quotes`):\n"
+ "# - Raw word: e.g. `param_name`\n"
+ "# - $parameter expansion: e.g. `$param_name`\n"
+ "# - ${parameter} expansion e.g. `${param_name}`\n"
+ "### ENDINFO\n\n"
+ "testvar\n"
+ " testvar\n"
+ " test_var \n"
+ " test5_var \n"
+ " test_var5 \n"
+ " $test_var\n"
+ " $test_var4\n"
+ " ${test_var4}";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}