$re = '/\b((\d|[a-zA-Z]{1,2})\d{7})\b/m';
$str = 'X1234567
PA1234567
12345678
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);